Issue with elevated error rates for uploads

Incident Report for Storj DCS

Resolved

The issue with elevated error rates for uploads has been resolved for all affected users.
The incident was limited to a region-specific storage tier in the United States.

We thank you for your patience while we worked on resolving the issue.
Posted Dec 10, 2025 - 23:52 UTC

Investigating

We are experiencing an issue with elevated error rates for uploads.
The incident is limited to a region-specific storage tier in the United States.

Our engineering team is actively investigating.

We apologize to all who are affected by the disruption.
Posted Dec 10, 2025 - 23:25 UTC
This incident affected: US1 (US1 - Select).