Issue with elevated error rates for uploads

Incident Report for Storj DCS

Resolved

The issue with elevated error rates for uploads has been resolved for all affected users.
The incident was limited to a region-specific storage tier in the United States.
Posted Dec 15, 2025 - 12:31 UTC
This incident affected: US1 (US1 - Select).